Install headache + solution + update to docs

doc

#1

Ok. So a recommendation for the docs / http://docs.pymc.io/index.html

It probably shouldn’t have taken me the entire evening, but I was having major install headaches. Things were working. There was an update to MacOS. Then they weren’t working. I was getting all kinds of cryptic messages. Anyway, to cut a 3-4 hour story short, it looks like some MacOS updates seem to play a bit of havoc with command line c++ compiler. My problem was eventually solved by:

command xcode-select --install

in order to reinstall the command line tools. It took me so long because I was getting vague compilation errors, but I already knew stuff worked and had installed a compiler ages ago. Anyway…

After that it all seemed to work no problem. Fresh install of Anaconda3 then

conda update --all
conda install -c conda-forge pymc3

then it was all working fine

Can I please recommend that the installation info (http://docs.pymc.io/index.html) is updated with a quick line to make people aware that they need a c++ compiler, and even though they may have installed one already, this is messed up by some MacOS updates. In which case the line command xcode-select --install does the job.

Thanks. If it saves someone else a headache, then that’s good


#2

It is a great idea. We should put up a page also listing some tips to set up and checking the environment such as MKL Intel (comes with Conda) etc. Maybe even some information on setting up PyMC3 on Google cloud and Amazon EC2.

@ericmjl do you have any information on this handy? I remember seeing some of your post talk about setup etc.


#3

@junpenglao this is the first time I’ve heard about this particular problem (post-macOS updates), but yes, in the past I’ve had issues with theano and the C++ compiler.

Thanks @drbenvincent for reporting this issue!