Installation Windows 10

Im having real trouble installing a fresh environment on Windows 10.
Ive installed MSYS2 and updated the Path variables as in:
Getting a Working Pymc3 Windows 10 Installation using Anaconda - An Installation Guide - Sharing - PyMC Discourse
Ive followed the conda install instructions on this site, and at this stage everything works fine. However when I try to run a basic model I get a compile error, saying ‘library blas is not found’
Later parts of the log refer to “D:\ProgramData\Anaconda\envs\pymc\Library\mingw-w64\bin\g++.exe”
When Ive checked gcc/g++ versions I get the following:

  • with a ‘normal’ command window I get v13.2
  • with conda, in the base env I get v13.2
  • with my pymc env activated I get 5.3
    If I rename the above dir ~pymc\Library\mingw-w64 then the version found is 13.2 (but I get other compile errors in PYMC)
    Is anyone able to offer a solution please?

Just to clarify, when you say you tried the instruction on this site, do you mean the pymc website, here?

The link you directed to is for pymc3, a project that is no longer maintained. Pymc3 was pretty hard to install on windows but the new package installs much more easily.

1 Like

Yeah sorry that really wasnt very clear - previously Id followed the procedure at the given link in order to pre-install up to date gcc/g++ via MSYS2, so I did this part (only) again to get the latest versions (13.2)
Then I swapped to the latest PYMC install instructions as per your link and installed v5.10.4 in a clean env.
FWIW setting:
pytensor.config.blas__ldflags = ‘’
Stops the compile error.
However, the following setting (to use the updated g++ etc) causes even more compile errors:
pytensor.config.cxx = “C:\msys64\ucrt\bin\g++.exe”
Does anyone have any insight on whats going on and how best to configure pytensor (etc) settings to get the optimum versions/speed etc?

1 Like

A few things spring to mind:

  1. At least with the new installation setup post-pymc3, I haven’t needed to explicitly change path variables to add mingw64 stuff. I imagine you 've tried a fresh install with conda create -c conda-forge -n pymc_env "pymc>=5" before you started messing around with the old discourse guide. But in case you haven’t, maybe try to revert path variable business because that could be interfering.

  2. A few months ago I remember having a problem where I installed a fresh pymc with the command above but blas didn’t come with. You can just install blas on its own if it is missing, with a regular conda install blas.

1 Like

In general, it can be difficult to create an environment based on one set of packages and their dependencies/channels and then try to install a new set of packages with their (potentially different) dependencies/channels into that existing environment. That’s why the installation instructions are written the way they are. If they are not working for you, please let us know and we can try to figure out what’s going on.

1 Like
  1. this is the odd thing - Ive used PYMC for a number of years, since v3 in fact, and yes past installs have been painful at times, but improving. So I really dont follow what has changed in my setup.
    If I stick with the default installed version of g++ (v5.3 in ~envs\pymc\Library\mingw-w64\bin) then the newer MSYS version shouldnt have any effect.
  2. blas and libblas etc are already installed. Ive tried to re-install blas and the same compile error occurs

Im not sure I follow - other than updating gcc/g++ in a completely separate location (C:\msys64) then I have followed the PYMC install instructions exactly as given, and as mentioned above, this has worked previously. It would also appear that v5.3 g++ is bundled with PYMC, and used by default?
Given the compile errors, and also bearing in mind the comments in my previous link: Getting a Working Pymc3 Windows 10 Installation using Anaconda - An Installation Guide
suggesting updating to a more recent g++, I started to look here first for the source of the error, hence the comments about msys paths in my original post.

CC @lucianopaz @maresb

Could you please share the output of the following command? Thanks!

conda config --show-sources
==> C:\Users\dave\.condarc <==
  - defaults

However, everything Ive installed has come from conda-forge