Running Pymc in clusters - CPU problems


I am recently running my code on ComputeCanada’s cluster. When I assigned node, cpu, and ram for each job, my modelling for multivariate logistic regression does not run at all depending on the setting. I mentioned “chains” with 4 chains, but I did not use “cores” for specific number of cpus in my pm.sample.

For example, when I ran the code with 1 cpu with 128 GB ram, it runs my code (although it is somewhat slow). However, when I ran the code with 4 cpu with 32 GB, sampling does not start at all until the designated job hours ended. Very weirdly, all codes run at my local laptop although it is also quite slow too.

Are there any researchers who experienced the same situation? If possible, could you let me know what poses this problem?

Hi Jinyoung,

I’ve not personally encountered this specific problem, especially that things seem to run “smoothly” on your local laptop. I am also not very familiar with Compute Canada’s system, but I’ve used it before. However, I am also a PhD student at UofT (and a PyMC dev!) and I am often on campus, so, if you need a pair of eyes to look at what’s going on, I can offer to help investigate further. Let me know! In the meanwhile, I hope that you find a solution to what you’re encountering.



1 Like

Hi Larry,

Thanks for your reply. Actually, I saw some of your activities in PyMC discourse in the past and recognized that you are in Dalla Lana Public Health School. I also attended a Bayesian course from BioStats in the previous term. I’ll let you know if I need further help.

Take care,


1 Like