Are there any changes with az.plot_forest(), with update?

Hi there :
I ran two simple models and captured their sample with pm.sample() as trace_1 and trace_2. and I wanted to visualize their parameters so I ran:
which is giving me this error below

/usr/local/lib/python3.7/dist-packages/theano/compile/function/ in __call__(self, *args, **kwargs)
    973             outputs = (
    974                 self.fn()
--> 975                 if output_subset is None
    976                 else self.fn(output_subset=output_subset)
    977             )

ValueError: Input dimension mis-match. (input[4].shape[0] = 50, input[7].shape[0] = 100)
Apply node that caused the error: Elemwise{Composite{Switch(i0, (i1 * ((i2 * i3 * sqr((i4 - (i5 + (i6 * i7))))) + i8)), i9)}}(Elemwise{Composite{Cast{int8}(GT(i0, i1))}}.0, TensorConstant{(1,) of 0.5}, TensorConstant{(1,) of -1.0}, InplaceDimShuffle{x}.0, D_std, InplaceDimShuffle{x}.0, InplaceDimShuffle{x}.0, WH_std, Elemwise{Composite{log((i0 * i1))}}.0, TensorConstant{(1,) of -inf})
Toposort index: 9
Inputs types: [TensorType(int8, (True,)), TensorType(float64, (True,)), TensorType(float64, (True,)), TensorType(float64, (True,)), TensorType(float64, vector), TensorType(float64, (True,)), TensorType(float64, (True,)), TensorType(float64, vector), TensorType(float64, (True,)), TensorType(float32, (True,))]
Inputs shapes: [(1,), (1,), (1,), (1,), (50,), (1,), (1,), (100,), (1,), (1,)]
Inputs strides: [(1,), (8,), (8,), (8,), (8,), (8,), (8,), (8,), (8,), (4,)]
Inputs values: [array([1], dtype=int8), array([0.5]), array([-1.]), array([0.97057715]), 'not shown', array([-0.01597757]), array([0.9873047]), 'not shown', array([-1.86774145]), array([-inf], dtype=float32)]
Outputs clients: [['output']]

HINT: Re-running with most Theano optimization disabled could give you a back-trace of when this node was created. This can be done with by setting the Theano flag 'optimizer=fast_compile'. If that does not work, Theano optimizations can be disabled with 'optimizer=None'.
HINT: Use the Theano flag 'exception_verbosity=high' for a debugprint and storage map footprint of this apply node.

pm.version =3.11.2
az.version =0.11.2

I think I was running the same code a few days back which ran without the errors. The only thing that I changed is the version. or Also I may have been wrong !!
Thanks in advance!!

This doesn’t look like an issue with plot_forest but like an issue with the conversion to InferenceData instead. Does this same error happen with az.from_pymc3(trace_1) (within the model context)? Which theano version do you have installed?

theano.version : 1.1.2
Thanks; Ohh I didn’t convert it to Inference data. I guess; previously I was working with older versions of Pymc3 which didn’t require this conversion. Do every model information has to be inference Data now?

I don’t understand the question, sorry.

If using arviz (also pymc plots and stats have been aliases for ArviZ since 3.8 or 3.9, not sure which version) the conversion was always happening but it did so under the hood (under the hood conversion is still happening, and is the root of your error). But, 1) this conversion depends on pymc arviz and theano/aesara versions, and 2) pymc-arviz integration has been improving progressively, so the conversion depends more on the model object. It is therefore relatively easy for the “so automatic you don’t even know it’s happening” conversion to fail.

I strongly recommend using return_inferencedata=True or converting explicitly to avoid the constant conversion overhead and to make sure you get the best conversion and it doesn’t fail.