Pymc-bart cannot install on Python version 3.11.0; only versions>=3.7,<3.11 are supported

After installing pymc through conda create -c conda-forge -n pymc_env “pymc>=4”, I got error: “cannot install on Python version 3.11.0”, when installing pymc-bart. Whether the new pymc is not compatible with PyMC-BART.

We haven’t tested if pymc is compatible with Python 3.11 and therefore not released it yet. It usually takes some time for Python’s ecosystem to catch up with new major releases.

Thanks, I’m really looking forward that the pymc_bart 0.2.0 will compatible with pymc 4.3.0 releases.

It might already be compatible, it seems the problem is you are trying to install in Python3.11, try with Python3.10 instead

As you recommend using [Anaconda] to install Python on my local machine. I installed PyMC into a new conda environment as follows: conda create -c conda-forge -n pymc_env “pymc>=4”. However, the Python = 3.11 in this new conda environment. * I’m very confused about whether I can degrade the version of python for Pymc_Bart.

Yes it should be fine to set python=3.10 when defining the new conda environment

@maresb did I overlook something here? And if not, should we update the installation instructions?

1 Like

The problem is that pymc-bart depends on numba which is not yet 3.11-compatible.

BTW, would you like a conda-forge package for pymc-bart? Apart from the CF approval process, it would only take me a minute. That way we don’t have to have people messing around with pip install inside a Conda environment, which is asking for trouble.

2 Likes