Pymc installation issue

Hello, I’m having an issue installing pymc v4. I’m using Windows 10, and I followed installation instructions here. Everything got installed smoothly (including mingw install with choco) with no error messages. When I try importing pymc I get the following:

Could not locate executable g77
Could not locate executable f77
Could not locate executable ifort
Could not locate executable ifl
Could not locate executable f90
Could not locate executable DF
Could not locate executable efl
WARNING (aesara.tensor.blas): Using NumPy C-API based implementation for BLAS functions.

After that I tried to install pymc in WSL2 (Ubuntu), but I get PackageNotFoundError. I tried both links, and I get this error both times. Any advice on next steps? I would prefer to install pymc in Windows without having to go through WSL2 (but only WSL2 install worked for me for pymc3). Thank you!!

When you see those messages, is pymc successfully imported anyway? Or is there an error and the import fails?

pymc was imported successfully. I was able to set up and sample a simple toy model. Model setup took a long time, but actual sampling seems reasonable (time-wise).

I got this warning but since I’m using python 3.9 it should be benign:

C:\Users\kuvychko\Anaconda3\envs\pymc_py39\lib\site-packages\pymc\ UserWarning: The parameter 'updates' of aesara.function() expects an OrderedDict, got <class 'dict'>. Using a standard dictionary here results in non-deterministic behavior. You should use an OrderedDict if you are using Python 2.7 (collections.OrderedDict for older python), or use a list of (shared, update) pairs. 

The slowness is related to the BLAS warning you are getting. Could you see if this thread helps at all? It’s about v3, but it may still be relevant.

Thanks for the link! I created .aesararc.txt in C:\Users*username* with the following content:


Now pymc import doesn’t show any flags and BLAS warning went away. The model runs quickly, so it looks like it fixed the issue for me. This may be worth putting into installation instructions.

Can you by any chance explain what is going on here and why this works? Thanks!


Glad it works! Yes, the installation instructions, particularly for Windows installations, are currently being re-evaluated. With v4 coming (soon), they will undoubtedly be solidified in the near future.

Forgot to address this question. But the short answer is no! I have no idea and don’t have any Windows installations to test that or anything else on. I know there are various Windows-specific challenges and I know where to find (somewhat) up-to-date discussion/solutions, but that’s about all I’ve got. More info might be here?

Thanks! Yeah, Windows install is a challenge, I’m glad I don’t have to go through WSL2 anymore!