Progress bar not showing in PyMC3 3.11.1

Hi, I have recently updated pymc3 from 3.8 to the 3.11.1 version, but since then the progress bar is no longer showing when I am running the following line:

pm.sample(tune=1000, chains=2, cores=1, return_inferencedata=True, progressbar=True)

What I am seeing now is only the following, which is not convenient since I need to run it on a larger dataset where the program will take quite a while to end.

Auto-assigning NUTS sampler…
Initializing NUTS using jitter+adapt_diag…
Sequential sampling (2 chains in 1 job)
NUTS: [sigma, beta_2, beta_1, alpha]

Any advice? Thank you in advance.

Hi @yyxx

Can you give more details, what platform are you working on? And how are you running it: Terminal / Jupyter / Etc?

I am using PyCharm on Windows, and I ran it in a python script. Also I use theano-pymc==1.1.2, not sure if this could be related?

See the GitHub issue where I raised this issue
here and the hacky solution here. In the end I didn’t want to edit my PyMC3 source files on every computer and environment so I learned to live without the progress bar.

Hi, I found the following solution here . You can simply import:

from fastprogress import fastprogress
fastprogress.printing = lambda: True

This worked for me just fine, I hope it helps.

2 Likes