Pycharm cannot show progress bar while Jupyter Notebook shows well after upgrade the PyMC3 to 3.9.3

I am testing the same code in Pycharm and Jupyter Notebook. However, Pycharm is not showing the progress bar after I upgrade PyMC3 from 3.7 to 3.9.3. Jupyter Notebook still shows the progress bar well.

Hi @yuanjinghui,

We recently (3.8 or 3.9, I don’t remember) switched to fastprogress.
The problem is probably more related to fastprogress than to PyMC3, so please try the following:

  1. make sure you have installed a recent/latest version of fastprogress
  2. try to use just fastprogress without PyMC3 in Pycharm (e.g. their Example 1)

If the problem persists, it will be interesting to see if the progress bar is only missing when created through PyMC3, or also if it’s just the standalone example.

1 Like

Thank you very much, @michaelosthege.

  1. My version of fastprogress is the latest version.
  2. I’ve tested Example 1 and the problem persists.

I think the problem is from Pycharm. I also tried to enable the “Emulate terminal in output console” in Pycharm (as suggested in this link, the progress bar is still not showing.

Thanks again.

This confirms that the issue lies with the combination of fastprogress and PyCharm.
I am not familiar with PyCharm myself, so I’d recommend to research the problem with the developers of fastprogress. This existing issue looks like what you’re describing:

1 Like

Yes, I agree. I will try to research with fastprogress developers.